Odd WoW graphX bug

While rummaging through several old WoW screenshot folders for an upcoming article, I came across this super weird snapshot I took of my character screen a while ago – quite possibly the oddest graphX glitch ever??

What on earth happened there..?
(and no, I don’t play gnomes – this is just a mule)

8 comments

  1. What on earth happened there..?

    Are you referring to the glitch or to the appearance of that monstrosity? =D

    It’s amazing that someone who will spend hours choosing a hairstyle or looking at dresses created such a thing. <3

  2. lol I wish I could take credit for this – but I was as baffled as anyone when it appeared on my login screen. oO
    for a second I actually pondered the possibility of this being holiday-related (but then I have never heard of a holiday where people wear checkered cubes on their heads??).

  3. If I had to guess(which is just a nice intro to say I’m going take a guess) I’d say it’s the default model whenever a model is missing. Most engines have something similar so that they don’t crash when a model can’t be loaded(and so it’s really really obvious that there’s a model missing).

  4. It’s the default model for anything in wow when there is no texture or, for some reason, the game couldn’t find the texture to apply to it.

    One of the forthcoming Worgen NPCs, Darius Crowley kept getting referred to as “Lord Boxhead” for a similar reason when his top hat got replaced by the checkered box for several beta builds :)

Leave a Reply to GBrookshaw Cancel reply

Your email address will not be published. Required fields are marked *

 characters available